Recently, we’ve noticed that some users have encountered a few issues after they ran Windows Updates on their GP/SQL Server, along with other various patches. Apparently after the Windows updates were completed and the GP/SQL Server rebooted, their GP Web Services stopped working, and they could not launch the GP Web Services Security Console, or the GP Web Services Exception Management Console without receiving errors. Some have attempted to roll back the Windows Updates hoping that this would remedy the situation, however the GP Web Services still would not work properly.

After we did some digging around on the server, it was decided it would be best to perform a complete uninstall and re-install of the GP Web Services. After the application was uninstalled, we then ran scripts in SQL to remove all of the SQL Objects used for the GP Web Services on both the DYNAMICS Database, along with all of the GP Company Databases.

Following a reboot of the GP/SQL Server, we then proceeded with the re-install of GP Web Services, and encountered further issues when we received the following error when inputting in the SQL Server information needed for the GP Web Services installation:

Once this error is received, there is no getting past it, and we ultimately have not choice but to abort the installation. After doing some additional researching online and further discussion, we then find out that along with doing the Windows Updates on the GP/SQL Server, that the customer had also disabled TLS 1.0 on the SQL Server in favor of using TLS 2.0.

TLS 1.0 is an industry standard security protocol that was developed in the early 90’s, and is slowly being deprecated and being replaced with newer versions of TLS. We’re seeing customers more frequently who are looking to get away from using TLS 1.0 and instead start using TLS 2.0 to be more PCI compliant. In most cases, we haven’t seen too many issues with doing this – until now.

Apparently with the standard Dynamics GP Client, there are no issues with using TLS 2.0, and disabling TLS 1.0, however this is not the case with the GP Web Services. For some odd reason, Microsoft still requires the use of TLS 1.0 with this product. Even with the latest GP 2018, TLS 1.0 is still required when installing the GP Web Services.

Now that we see this, we then re-enable TLS 1.0 on the SQL Server, and then after a reboot of the GP/SQL server, we are then able to properly install the GP Web Services with no errors, or issues.  According to Microsoft, if you still want to disable TLS 1.0 after the installation of GP Web Services is complete, you can for time being. It is a must for the proper installation of the GP Web Services

To learn more about how you can take advantage of this and other Dynamics GP features, visit RSM’s Microsoft Dynamics GP resource. To make sure you stay up to date with the Microsoft Dynamics Community, subscribe to our Microsoft Dynamics Community Newsletter. For more information on Microsoft Dynamics 365, contact us.

By: George Olsen

Tagged with →